Network problems

Use this information to resolve issues related to networking.

Cannot wake server using Wake on LAN

Complete the following steps until the problem is resolved:
  1. If you are using the dual-port network adapter and the server is connected to the network using Ethernet 5 connector, check the system-error log or IMM2 system event log (see Event logs), make sure:
    1. Fan 3 is running in standby mode, if Emulex dual port 10GBase-T embedded adapter is installed.

    2. The room temperature is not too high (see Specifications).

    3. The air vents are not blocked.

    4. The air baffle is installed securely.

  2. Reseat the dual-port network adapter.

  3. Turn off the server and disconnect it from the power source; then, wait 10 seconds before restarting the server.

  4. If the problem still remains, replace the dual-port network adapter.

Could not log in using LDAP account with SSL enabled

Complete the following steps until the problem is resolved:
  1. Make sure that the license key is valid.

  2. Generate a new license key and log in again.

Server could not connect to the Wi-fi

Complete the following steps until the problem is resolved:

  1. Log into Lenovo XClarity Controller (change password for the first-time log in). Enable Wi-Fi Connectivity and input the information of the existing Wifi.

    Note: Server supports WPA2 only.
    Figure 1. Network setting
    Network setting
  2. If server still cannot connect to the Wi-fi, repeat step one or check if WLAN module is enabled by using the command through OpenWRT:

    dmesg | grep RTW

    See example:

    oper@OpenWrt:/etc/config$ dmesg | grep RTW
    RTW: module init start
    RTW: rtl88x2be v5.2.21.5_30361.20181019
    RTW: build time: May 30 2019 04:00:44
    RTW: rtl88x2be BT-Coex version = COEX20180824-6666
    RTW: rtw_inetaddr_notifier_register
    RTW: Memory mapped space start: 0x4040000000 len:00010000 flags:00140204, after map:0xffff00000e2d0000
    RTW: CHIP TYPE: RTL8822BE
    RTW: Bus master is enabled. usPciCommand=7
    RTW: PCIe Header Offset =70
    RTW: PCIe Capability =2
    Link Control Register =40
    RTW: Clock Request =0
    

Sever could not be set as WLAN AP mode

Complete the following steps until the problem is resolved:

  1. Log into Lenovo XClarity Controller (change password for the first-time log in). Enable Wi-Fi Connectivity and input the information of AP mode.

    Note: Server supports WPA2 only.
    Figure 2. Network setting
    Network setting
  2. If server still cannot work in AP mode, repeat step one or check the AP mode status by using the command through OpenWRT:

    sudo uci show wireless

    For example:

    oper@OpenWrt:/tmp$ sudo uci show wireless
    wireless.radio0=wifi-device
    wireless.radio0.type='mac80211'
    wireless.radio0.channel='11'
    wireless.radio0.hwmode='11n'
    wireless.radio0.path='soc/3400000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
    wireless.radio0.disabled='0'
    wireless.radio0.htmode='HT40'
    wireless.radio0.country='TW'
    wireless.default_radio0=wifi-iface
    wireless.default_radio0.device='radio0'
    wireless.default_radio0.network='wifi_lan_ap'
    wireless.default_radio0.mode='ap'
    wireless.default_radio0.ssid=' SE350_ap3'
    wireless.default_radio0.encryption='psk2'
    wireless.default_radio0.key='password'
    wireless.default_radio0.maxassoc='8'
    oper@OpenWrt:/tmp$
    

LTE connection failed

Complete the following steps until the problem is resolved:

  1. Log into Lenovo XClarity Controller (change password for the first-time log in). Enable LTE Connectivity and apply the change.

    Figure 3. Network setting
    Network setting
  2. To check if LTE module is successfully enabled, connect the server to OpenWRT via SSH (default = 192.168.70.254) and use the command below:

    oper@OpenWrt:/tmp$ sudo ifconfig

    It shows wwan0 if LTE module is successfully enabled. For example:

    oper@OpenWrt:/tmp$ sudo ifconfig 
    …
    wwan0     Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
                      inet addr:10.0.148.227  P-t-P:10.0.148.227  Mask:255.255.255.248
                      inet6 addr: fe80::244a:5b3e:11a9:aee7/64 Scope:Link
                     UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1500  Metric:1
                     RX packets:110700 errors:0 dropped:0 overruns:0 frame:0
                     TX packets:45977 errors:0 dropped:0 overruns:0 carrier:0
                     collisions:0 txqueuelen:1000
                      RX bytes:160842733 (153.3 MiB)  TX bytes:2001645 (1.9 MiB)

Config LTE in Linux

Complete the following steps until the problem is resolved:

  1. QMI mode is required for LTE mode in Linux. Connect the server to OpenWRT via SSH (default = 192.168.70.254) and use the command below:

    sudo usbmode_switch_telit_openwrt.sh

For example:

oper@OpenWrt:/tmp$ sudo usbmode_switch_telit_openwrt.sh
/sys/bus/usb/devices/2-1
LN940 at MBIM mode, change to QMI mode.
oper@OpenWrt:/tmp$ sudo reboot